Google Analytics for WooCommerce

Description

This plugin provides the integration between Google Analytics and the WooCommerce plugin. You can link a referral to a purchase and add transaction information to your Google Analytics data. It supports Global Site Tag (GA4) and eCommerce event tracking.

Please visit the documentation page for additional information.

Contributions are welcome via the GitHub repository.

Screenshots

  • Google Analytics Integration Settings.

Installation

  1. Download the plugin file to your computer and unzip it
  2. Using an FTP program, or your hosting control panel, upload the unzipped plugin folder to your WordPress installation’s wp-content/plugins/ directory.
  3. Activate the plugin from the Plugins menu within the WordPress admin.
  4. Don’t forget to enable e-commerce tracking in your Google Analytics account: https://support.google.com/analytics/answer/1009612?hl=en

Or use the automatic installation wizard through your admin panel, just search for this plugin’s name.

FAQ

Where can I find the setting for this plugin?

This plugin will add the settings to the Integration tab, found in the WooCommerce → Settings menu.

I don’t see the code on my site. Where is it?

We purposefully don’t track admin visits to the site. Log out of the site (or open a Google Chrome Incognito window) and check if the code is there for non-admins.

Also please make sure to enter your Google Analytics ID under WooCommerce → Settings → Integrations.

My code is there. Why is it still not tracking sales?

Duplicate Google Analytics code causes a conflict in tracking. Remove any other Google Analytics plugins or code from your site to avoid duplication and conflicts in tracking.

Reviews

ഏപ്രിൽ 1, 2024 3 replies
The plugin for some reason stopped recording Purchase events. Add to cart and other events are recorded properly but the most important one shows 0 in GA4.
മാർച്ച്‌ 28, 2024 5 replies
I used this plugin for over 2 years without any issues. However, since the release of 2.0.0 it's just not usable anymore. My biggest issue is with the invalid value of purchase events. Due to formatting error, the conversion value was increased hundredfold. It cannot be deleted via GA4 deletion requests as devs suggested, because it is not possible to remove numeric values, so I'm stuck with them forever. It might not be a big deal to some, but to me, it's a deal breaker. I switched to another plugin. Sure it's free, but stuff like these should be caught in tests before release..
മാർച്ച്‌ 26, 2024 3 replies
Stopped recording data on GA4. Switched off various plugins to check for a compatibility issue and the only thing that worked was to roll this back to 1.8.14. Raised a bug report and was told it was 'one of the other plugins and to do some compatibility testing'.
മാർച്ച്‌ 25, 2024 3 replies
Unfortunately the last version of this plug-in that works on my site (toxicgarb.com) is 1.8.13. Somehow, it stops page content from loading correctly, primarily images.Will now see if the support team are as good as suggested or whether I get the often used "there's a conflict due to another plug-in" comment. Fingers crossed.
Read all 106 reviews

Contributors & Developers

“Google Analytics for WooCommerce” is open source software. The following people have contributed to this plugin.

Contributors

“Google Analytics for WooCommerce” has been translated into 12 locales. Thank you to the translators for their contributions.

Translate “Google Analytics for WooCommerce” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

2.0.6 – 2024-04-09

  • Tweak – WC 8.8 compatibility.

2.0.5 – 2024-04-04

  • Tweak – Register woocommerce-google-analytics-integration script earlier, so other extensions can plug in.
  • Update – Separate the site tag from the event tracking file and delay execution until DOMContentLoaded.

2.0.4 – 2024-03-26

  • Dev – Add QIT workflow.
  • Dev – E2E tests for the All Products block.
  • Dev – Remove unused functions from code.
  • Fix – Warning after plugin install using wp-cli.
  • Tweak – Add WP 6.5 Require plugins header.

See changelog for all versions.